Algorithme exercices corrigés | Exam-Lib
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Welcome to our Education website, plz like our page facebook to support us. Thank You and wish you good navigation

Algorithme exercices corrigés

abdelouafiApr 21, 2018

    1. abdelouafi

      abdelouafi Administrator Staff Member

      Messages:
      815
      Likes Received:
      14
      Trophy Points:
      18
      Joined
      Sep 13, 2016
      Exercice 1
      • Quelles seront les valeurs des variables A et B après exécution des instructions suivantes ?

      Code:
      Algorithme test;
      Var A,B:Entier
      début
      A←1
      B ←A+3
      A←3
      Fin
      Exercice 2
      • Quelles seront les valeurs des variables A, B et C aprèsexécution des instructions suivantes ?
      Code:
      Algorithme test2;
      Var A,B,C:Entier;
      début
      A←5
      B←3
      C←A+B
      A←2
      C←B–A
      fin
      
      



      Exercice 3
      • Quelles seront les valeurs des variables A et B après exécution des instructions suivantes ?

      Code:
      Algorithme test3;
      Var A, B : Entier
      début
      A← 5
      B← A + 4
      A← A + 1
      B← A –4
      fin

      Exercice 4
      •Quelles seront les valeurs des variables A, B et C après exécution des instructions suivantes ?
      VarA,B,C:Entier;
      début
      A←3;

      B←10;
      C←A+B;
      B←A+B;
      A←C;
      fin.



      Exercice 5
      • Quelles seront les valeurs des variables A et B après exécutiondes instructions suivantes ?
      VarA,B:Entier
      début
      A← 5

      B← 2
      A← B
      B← A
      fin.

      Exercice 6
      • Ecrire un algorithme permettant d’échanger les valeurs de deux variable sA et B.?



      Exercice 7
      •On dispose de trois variables A, B et C. Ecrivez un algorithme transférant à B la valeur de A, à C la valeur de B et à A lavaleur de C.


      Exercice 8
      • Que produit l’algorithme suivant ?
      Var A, B, C : Caractères
      début
      A ← "423 " ;
      B ← "12 " ;

      C ← A + B;
      fin.


      Exercice 9
      •Que produit l’algorithme suivant ?
      Var A, B, C : Caractères
      début
      A ← "423 " ;
      B ← "12 " ;

      C ← A & B;
      fin.


      Exercice 10
      •Quel résultat produit le programme suivant ?
      algorithme double;
      Var val, Double: entier;
      début
      Val ← 231;

      Double ← Val * 2;
      Ecrire (Val);
      Ecrire (Double);
      fin.



      Exercice 11
      •Ecrire un programme qui demande un nombre à l’utilisateur,puis qui calcule et affiche le carré de ce nombre.?


      Exercice 12
      •Ecrire un programme qui lit le prix HT d’un article, le nombre d’articles et le taux de TVA, et qui fournit le prix total TTC correspondant. Faire en sorte que des libellés apparaissent clairement. (TTC=NA*HT*(1+TVA))?


      Exercice 13
      •Ecrire un algorithme qui demande un nombre à l’utilisateur,et l’informe ensuite si ce nombre est positif ou négatif (on laisse de côté le cas où le nombre vaut zéro).

      Exercice 14
      Ecrire un algorithme qui demande deux nombres à l’utilisateur et l’informe ensuite si leur produit est négatif ou positif(on laisse de côté le cas où le produit est nul).Attention toute fois on ne doit pas calculer le produit des deux nombres.

      Exercice 15
      • Ecrire un algorithme qui demande trois noms à l’utilisateur et l’informe ensuite s’ils sont rangés ou non dans l’ordre alphabétique.


      Exercice 16
      • Ecrire un algorithme qui demande un nombre à l’utilisateur,et l’informe ensuite si ce nombre est positif ou négatif (on inclus cette fois le traitement du cas où le nombre vaut zéro).

      Exercice 17
      • Ecrire un algorithme qui demande deux nombres à l’utilisateur et l’informe ensuite si le produit est négatif ou positif (on inclut cette fois le traitement du cas où le produit peut être nul).


      Exercice 18
      • Ecrire un algorithme qui demande l’âge d’un enfant à l’utilisateur.Ensuite,il l’informe de sa catégorie:
      •"Poussin" de 6 à 7 ans
      •"Pupille" de 8 à 9 ans
      •"Minime" de 10 à 11 ans
      •"Cadet" après 12 ans
      Peut-on concevoir plusieurs algorithmes équivalents menant à ce résultat?

      Exercice 19

      Ecrire un algorithme qui demande un nombre de départ,et qui ensuite affiche les dix nombres suivants. Par exemple, si l'utilisateur entre le nombre 17,le programme affichera les nombres de 18 à 27.


      Exercice 20
      •Ecrire un algorithme qui demande un nombre de départ,et qui calcule la somme des entiers jusqu’à ce nombre. Par exemple, si l’on entre 5,le programme doit calculer:1+2+3+4+5=15


      Exercice 21
      •Ecrire un algorithme qui demande un nombre de départ,et qui calcule sa factorielle.



      Exercice 22-A
      •Ecrire un algorithme qui demande successivement 20 nombres à l’utilisateur,et qui lui dit ensuite quel était le plus grand parmi ces 20 nombres.




      Exercice 22-B
      •Modifiez ensuite l’algorithme pour que le programme affiche de surcroît en quelle position avait été saisie ce nombre.



      Exercice 23
      •Réécrire l’algorithme précédent, mais cette fois-ci on ne connaît pas d’avance combien l’utilisateur souhaite saisir de nombres.La saisie des nombres s’arrête lorsque l’utilisateur entre un zéro.
       
      Last edited: Apr 23, 2018
      Loading...

      Merci de partager ce post sur facebook

      Exercice 1:
      La valeur des variables sont:
      A=3 et B=4

      Exercice 2:
      A=2 et B=3 et C=1

      Exercice 3:
      A=6 et B=2

      Exercice 4

      A=13

      B= 13 et C=13


      Exercice 5:

      A=2 et B=2



      Exercice 6:


      Code:
      algorithme permutation;
      
      Var A,B,C:Entier;
      
      début
      
      
      
      Lire(A);
      
      Lire(B);
      
      C ← A;
      
      A ← B;
      
      B ← C;
      
      Ecrire(A);
      
      Ecrire(B);
      
      fin



      Exercice 7 :

      Code:
      Algorithme permutation;
      
      Var A,B,C,D:Entier;
      
      
      Début
      
      Lire(A);
      
      Lire(B);
      
      Lire(C);
      
      D ← C;
      
      C ← B;
      
      B ← A;
      
      A ← D;
      
      Ecrire(A);
      
      Ecrire(B);
      
      Ecrire(C);
      
      Fin.



      Exercice 8 :

      Il ne peut produire qu’une erreur d’exécution, puisqu’on ne peut pas additionner des caractères.



      Exercice 9 :

      En revanche,on peut les concaténer.A la fin de l’algorithme,C vaudra donc "42312".


      Exercice 10 :

      On verra apparaître à l’écran 231, puis 462 (qui vaut 231 * 2)

      Exercice 11 :

      Code:
      Algorithme carré;
      
      Var nb, carr : Entier;
      
      
      début
      
      Ecrire( "Entrez un nombre : ");
      
      Lire (nb);
      
      carr ← nb * nb;
      
      Ecrire ( "Son carré est : " , carr);
      
      fin.


      Exercice 12 :

      Code:
      algorithme prix TTC d’un article;
      
      var n, pt, ttva, pttc :réel
      
      début
      
      Ecrire ("Entrez le prix hors taxes : ");
      
      Lire (pht);
      
      Ecrire( "Entrez le nombre d’articles :" );
      
      Lire (nb);
      
      Ecrire ("Entrez le taux de TVA :");
      
      Lire (ttva);
      
      pttc ← nb * pht * (1 + ttva);
      
      Ecrire ("Le prix toutes taxes est : ", pttc);
      
      fin


      Exercice 13 :


      Code:
      Algorithme test positif ou négatif;
      
      Var n : Entier;
      
      début
      
      Ecrire ("Entrez un nombre : " );
      
      Lire (n);
      
      Si n > 0 Alors
      
      Ecrire ("Ce nombre est positif”);
      
      Sinon
      
      Ecrire ("Ce nombre est négatif ");
      
      Finsi
      
      fin.


      Exercice 14 :

      Code:
      Algorithme test produit positif ou négatif;
      
      début
      
      Ecrire ("Entrez deux nombres : ");
      
      Lire (m);
      
      Lire(n);
      
      Si (m > 0 ET n > 0) OU (m < 0 ET n < 0) Alors
      
      Ecrire ("Leur produit est positif ");
      
      Sinon
      
      Ecrire ("Leur produit est négatif ");
      
      Finsi
      
      fin.



      Exercice 15 :



      Code:
      algorithmeordre alphabétique;
      
      Var a, b, c : Caractère
      
      
      début
      
      Ecrire ("Entrez successivement trois noms : ");
      
      Lire(a); Lire(b);
      
      Lire(c);
      
      Si (a < b ET b < c) Alors
      
      Ecrire ("Ces noms sont classés alphabétiquement");
      
      Sinon
      
      Ecrire ("Ces noms ne sont pas classés ");
      
      Finsi
      
      fin

      Exercice 16 :

      Code:
      algorithme test positif ou négatif;
      
      Var n : Entier;
      
      début
      
      Ecrire ("Entrez un nombre : " );
      
      Lire (n);
      
      Si n < 0 Alors
      
      Ecrire ("ce nombre est négatif ");
      
      
      Sinon
      
      Si n = 0 Alors
      
      Ecrire ("Ce nombre est nul " );
      
      Sinon
      
      Ecrire ("Ce nombre est positif " );
      
      Finsi
      
      Finsi
      
      fin



      Exercice 17 :


      Code:
      Algorithme test;
      
      Var m, n : Entier;
      
      début
      
      Ecrire ("Entrez deux nombres : ");
      
      Lire m;
      
      Lire n;
      
      Si (m = 0 OU n = 0) Alors
      
      Ecrire ("Le produit est nul ");
      
      Sinon
      
      Si (m < 0 ET n < 0) OU (m > 0 ET n > 0) Alors
      
      Ecrire ("Le produit est positif ");
      
      Sinon
      
      Ecrire "Le produit est négatif«
      
      Finsi
      
      Finsi
      
      fin


      Exercice 18 :

      Code:
      Var age:Entier;
      
      début
      
      Ecrire("Entrezl’âgedel’enfant:");
      
      Lire(age);
      
      Si age>=12 Alors
      
      
      Si(age>=8) Alors
      
      Ecrire("CatégoriePupille");
      
      Sinon
      
        Si(age>=6) Alors
      
      
      Ecrire("CatégorieCadet");
      
      Sinon
      
          Si(age>=10) Alors
      
              Ecrire("CatégorieMinime");
      
                      Sinon
      
                           Ecrire("CatégoriePoussin");
      
                           Finsi
      
      Finsi
      
      Finsi
      
      Finsi
      
      fin

      Exercice 19 :

      Code:
      algorithme affichagedesnombres;
      
      Var N,i:Entier
      
      
      début
      
      Ecrire("Entrezunnombre:");Lire(N);Ecrire("Les10nombressuivantssont:");
      
      Pour i de N+1  à N+10  faire
      
      Ecrire(i);
      
      finpour
      
      fin


      Exercice 20 :

      Code:
      algorithme Somme;
      
      Var N,i,Som:Entier;
      
      Ecrire("Entrezunnombre:");
      
      Lire(N);
      
      Som←0;
      
      Pour i de 1 à N faire
      
      Som←Som+i;
      
      finpour
      
      Ecrire("Lasommeest:",Som);
      
      fin


      Exercice 21 :

      Code:
      algorithme Factorielle;
      
      Var N,i,F:Entier;
      
      début
      
      Ecrire("Entrezunnombre:");
      
      Lire(N);
      
      F←1;
      
      Pou r i de 2  à N  faire
      
      F← F*i;
      
      finpour
      
      Ecrire("Lafactorielleest:",F);
      
      fin

      Exercice 22-A :

      Code:
      algorithme PG_NBRparmis20;
      
      Var N,i,PG:Entier;
      
      début
      
      PG←0;
      
      Pour i  de 1  à 20  faire
      
      Ecrire("Entrezunnombre:");
      
      Lire(N);
      
      Si
      
      i=1 ou N>PG  Alors
      
      PG ← N;
      
      FinSi
      
      finpour
      
      Ecrire("Lenombreleplusgrandétait:",PG);
      
      fin

      Exercice 22-B :

      Code:
      algorithme PG_NBRparmis20;
      
      Var N,i,PG,IPG:Entier;
      
      début
      
      PG =0
      
      Pour i  de 1  à 20 faire
      
      Ecrire("Entrezunnombre:");
      
      Lire(N);
      
      Si
      
      i=1 ou N>PG  Alors
      
      PG← N;
      
      IPG←i;
      
      FinSi
      
      finpour
      
      Ecrire("Lenombreleplusgrandétait:",PG);
      
      Ecrire(«Ilaétésaisienposition:",IPG);
      
      fin
      

      Exercice 23 :

      Code:
      algorithme PG_NBR;
      
      Var N, i, PG, IPG : Entier;
      
      début
      
      N ← 1; i ← 0; PG ← 0;
      
      tant que N ≠ 0 faire
      
      Ecrire ("Entrez un nombre : " );
      
      Lire (N);
      
      i ← i + 1;
      
      Si i = 1 ou N > PG Alors
      
      PG ← N;
      
      IPG ← i;
      
      FinSi
      
      FinTantQue
      
      Ecrire ("Le nombre le PG était : ", PG);
      
      Fin.
      

Share This Page

Share